[Librem-5-dev] devkit flashing help

Aaron aaron.morand at gmail.com
Fri Sep 25 08:31:24 PDT 2020

Yes, it shows up via lsusb.  It is also recognised differently according to
the position of the USB Boot Mode switch.


On Fri, 25 Sep 2020 at 11:24, David Boddie via Librem-5-dev <
librem-5-dev at lists.community.puri.sm> wrote:

> On Date: Mon, 21 Sep 2020 10:23:28 -0400, Aaron wrote:
> > I've had this same issue with my dev-kit since I got it.  I had
> originally
> > gotten an externally powered USB-C hub to help with power issues, but I
> > still had this issue.  The battery idea sounded interesting and I have
> > tried that as well, with the same results.  I have also tried turning off
> > the kill switches for the wifi, wlan and camera/mic in hopes to minimize
> > power consumption, with no success.
> >
> > How do I get debug port output?  As per the documentation
> > <https://developer.puri.sm/Librem5/Hardware_Reference/devkit.html>, I
> have
> > only found the unpopulated JTAG and UART headers.  I would need to get
> > headers on one of those to be able to get the debug information
> mentioned?
> It's the UART you need to access with a header.
> Has the board ever appeared as a USB device when connected to a
> workstation?
> David
> _______________________________________________
> Librem-5-dev mailing list
> Librem-5-dev at lists.community.puri.sm
> https://lists.community.puri.sm/listinfo/librem-5-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.community.puri.sm/pipermail/librem-5-dev/attachments/20200925/66785c0f/attachment.html>

More information about the Librem-5-dev mailing list