[Librem-5-dev] Librem5 Devkit and `apt-get dist-uprade` notice

Guido G√ľnther agx at sigxcpu.org
Wed Jun 5 05:06:25 PDT 2019


Hi,
in order to prepare for using for 5.x kernels by default we adjusted the
device tree file names for the 4.18 kernel to match the linux-next
ones. So we now ship both imx8mq-librem5-devkit.dtb and librem5-evk.dtb
with identical content. On top of that we updated flash-kernel to look
for new imx8mq-librem5-devkit.dtb name as well.

You will not notice if you update by flashing new images, however if you
update via

  apt-get dist-upgrade

flash-kernel will get updated and your currently installed kernel package
might not yet have the imx8mq-librem5-devkit.dtb which makes
flash-kernel fail. In order to avoid that *either*:

1.) flash a new image
2.) grab a newer kernel from 

  https://arm01.puri.sm/job/Kernel_builds/job/kernel_devkit_linux-emcraft_imx8-4.18-wip/

  and install that before doing the dist-upgrade.
3.) Copy your currently used device tree to
    /etc/flash-kernel/dtbs/imx8mq-librem5-devkit.dtb
    before doing the dist-upgrade.

Cheers,
 -- Guido


More information about the Librem-5-dev mailing list